struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Tran" <dantt...@hotmail.com>
Subject Re: struts-el:submit question
Date Thu, 19 Dec 2002 21:18:02 GMT
Hi David,

First, the problem went away, and I cant reproduce it.
I could have been the way to declare html-el somehow mapped to the regular
strut html tag.

Second,   I have a form with a submit button's label varied depending on a
property of my action form bean, in this case it is an "action" property.

<snipped>
  <html-el:form    action="......" >
     <html-el:hidden property="action" >

      ....

     <html:submit value="${action}" />
</snipped>

Thank you for patiently helping me here

-D
----- Original Message -----
From: "Karr, David" <david.karr@attws.com>
To: "Struts Users Mailing List" <struts-user@jakarta.apache.org>
Sent: Thursday, December 19, 2002 12:36 PM
Subject: RE: struts-el:submit question


Putting the bean into your scope is certainly required, but neglecting to do
that shouldn't have caused the symptom you saw.  If the bean wasn't found,
it should have resulted in an empty string, not the string "${action}".

You'll have to be more specific than "how do I pick up the a property within
my form?".

> -----Original Message-----
> From: Dan Tran [mailto:danttran@hotmail.com]
>
> Hi David,
>
> It is my fault,  The variable action is a property of my
> form.  When I move
> it to the request object  via
> request.setAttribute("action", xxxx) before forward to the jsp then
> html-el:submit  works.
>
>
> Question,  how do I pick up the a property within my form?
>
> ie <html-el:submit value="${myform.var}"
>
> Thanks
>
>
>
> ----- Original Message -----
> From: "Karr, David" <david.karr@attws.com>
>
> We would need to see more of your real JSP code, including the taglib
> directives, and not just a "simulated" copy, but the real code.
>
> > -----Original Message-----
> > From: Dan Tran [mailto:danttran@hotmail.com]
> >
> > Hi,
> >
> > I have this code
> >
> > <snippet>
> >     <html-el:submit value="${action} />
> > </snippet>
> >
> > The sumbut button lable shows as ${action}, no translation
> >
> > What is wrong with my code?

--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message