struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From René Eigenheer <reigenh...@bridgesolutions.net>
Subject RE: off topic: classloader tomcat 4.0.x
Date Tue, 06 Aug 2002 16:12:08 GMT
you don't belive it ;-))) by preparing a "nice" mail describing all the
problems I faced, I got it to work:

the first test was to packk all in on war which leads to:
java.lang.NoClassDefFoundError: org/w3c/dom/events/EventTarget

then I moved xerces.jar to jboss/server/default/lib and let the rest of my
jars in the war ... and it worked - but I already did this before, but most
propably with a wrong version of xerces

thanks for your assistance

ps: now I switch to my next application and I'm curious to know what kind of
problems I will face with this one ;-)))


> -----Original Message-----
> From: Craig R. McClanahan [mailto:craigmcc@apache.org]
> Sent: Dienstag, 6. August 2002 17:48
> To: Struts Users Mailing List
> Subject: Re: off topic: classloader tomcat 4.0.x
>
>
> I don't know precisely where your problem lies, but I can
> guarantee you
> that putting struts.jar in a common directory (like
> common/lib) and your
> application beans inside the webapp is guaranteed to fail on
> Struts 1.0.
> It should work under 1.1, but hasn't been extensively tested.
>
> Does the Struts-example app work on the configuration you are running?
>
> Craig
>
>
> On Tue, 6 Aug 2002, René Eigenheer wrote:
>
> > Date: Tue, 6 Aug 2002 15:49:36 +0200
> > From: René Eigenheer <reigenheer@bridgesolutions.net>
> > Reply-To: Struts Users Mailing List <struts-user@jakarta.apache.org>
> > To: struts-user@jakarta.apache.org
> > Subject: off topic: classloader tomcat 4.0.x
> >
> > after hours of spending (wasting) time with upgrading to
> jboss 3 - tomcat 4
> > I'm close to give up ;-))
> >
> > I have some struts application which I'd like to migrate,
> but I do not find
> > a configuration, where all classes, ressource files are found
> >
> > I'm copying jars (struts, castor, xerces, own application)
> from WEB-INF/lib
> > to catalina/common/lib and vice versa and do also use jboss lib
> > directories -> but with every configuration I try, it
> doesn't load another
> > class (or message ressource).
> >
> > does anybody of you have a running example with these jars?
> >
> > does anybod know another documentation than tomcats
> class-loader-HOW-TO
> > which explains the class loading process (in special the
> loading of classes
> > which are referenced from a class in a jar)
> >
> > thanks for any help
> >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:struts-user-help@jakarta.apache.org>
> >
> >
>
>
> --
> To unsubscribe, e-mail:
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:struts-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message