struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fletcher, Ken" <ken.fletc...@trs.state.tx.us>
Subject RE: error running struts on iPlanet
Date Tue, 28 Aug 2001 20:57:44 GMT
I'll give it a try......thanks.

-----Original Message-----
From: Matt Raible [mailto:matt_raible@yahoo.com]
Sent: Tuesday, August 28, 2001 3:51 PM
To: struts-user@jakarta.apache.org
Subject: RE: error running struts on iPlanet


you are correct.

--- "Fletcher, Ken" <ken.fletcher@trs.state.tx.us> wrote:
> So then in the JSP:
> <html:form> 
> would actually be 
> <strutshtml:form>?
> 
> -----Original Message-----
> From: Matt Raible [mailto:matt_raible@yahoo.com]
> Sent: Tuesday, August 28, 2001 3:41 PM
> To: struts-user@jakarta.apache.org
> Subject: RE: error running struts on iPlanet
> 
> 
> we actually changed our taglib declaration to get around this problem to:
> 
> <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="strutshtml" %>
> 
> 
> --- "Paradis,_André" <andre.paradis@versalys.com> wrote:
> > Ken,
> > 
> > I ran across the same problem...
> > 
> > the tld declaration for struts-html declares a prefix of "html" for all
> > of its tags (like <"html:form>") etc.
> > 
> > When you put a "normal" html tag in your jsp page "<html>", iplanet
> > interpret that to <html:> (seems a bug to me...) and tries to find a tag
> > that does not exist.
> > 
> > To avoid changing the prefix,  replace <html> with <html:html> and all
> > should be fine. 
> > 
> > <html>
> > </html>
> > 
> > must be changed to:
> > 
> > <html:html>
> > </html:html>
> > 
> > Andre Paradis
> > 
> > > -----Original Message-----
> > > From: Fletcher, Ken [mailto:ken.fletcher@trs.state.tx.us]
> > > Sent: Tuesday, August 28, 2001 3:15 PM
> > > To: 'struts-user@jakarta.apache.org'
> > > Subject: error running struts on iPlanet
> > > 
> > > 
> > > Has anyone run across this error while trying to deploy a 
> > > struts app to
> > > iPlanet 6.0 SP2?
> > >  
> > > Error: 500 SC_INTERNAL_SERVER_ERROR
> > > JSP Error: Class was not found for :html
> > >  
> > > It runs fine using straight JSP's but when I use the 
> > > struts-html.tld it
> > > bombs.
> > >  
> > > Thanks,
> > > Ken
> > > 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Make international calls for as low as $.04/minute with Yahoo! Messenger
> http://phonecard.yahoo.com/


__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

Mime
View raw message