struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nigel Ainslie <NAins...@Trysoft.com>
Subject RE: class not found errors
Date Wed, 06 Jun 2001 01:24:06 GMT
so, is the first time you have tried to run the app or have you already had
it working using your existing directory structure and config files?
Often this error is a case sensitivity classname issue, or a directory path
issue....

-----Original Message-----
From: Zaremba, Don [mailto:dzaremba@ellacoya.com]
Sent: Wednesday, 6 June 2001 10:10
To: 'struts-user@jakarta.apache.org'
Subject: RE: class not found errors



Yes, I check those two (and double checked), they are ok


-----Original Message-----
From: Nigel Ainslie [mailto:NAinslie@Trysoft.com]
Sent: Tuesday, June 05, 2001 6:51 PM
To: 'struts-user@jakarta.apache.org'
Subject: RE: class not found errors


..have you made sure that all your declarations in your struts-config.xml
file match case-sensitive to the LogonForm.class (as opposed to Logonform or
logonForm etc) and made sure that in your jsp you have maintained case
sensitivity for calling your ".do" action class? 
Just a thought :-)

-----Original Message-----
From: Zaremba, Don [mailto:dzaremba@ellacoya.com]
Sent: Wednesday, 6 June 2001 8:31
To: 'struts-user@jakarta.apache.org'
Subject: RE: class not found errors


That was a typo, it was in webscm/logon


-----Original Message-----
From: Nigel Ainslie [mailto:NAinslie@Trysoft.com]
Sent: Tuesday, June 05, 2001 6:31 PM
To: 'struts-user@jakarta.apache.org'
Subject: RE: class not found errors


..is this just a typo or the cause of your error???
You say you have a class file in ellacoya/webwcm/logon but the output seems
to be looking in ellacoya/webscm/logon (i.e. webwcm vs webscm)
????
Cheers Nige

-----Original Message-----
From: Zaremba, Don [mailto:dzaremba@ellacoya.com]
Sent: Wednesday, 6 June 2001 7:55
To: struts-user@jakarta.apache.org
Subject: class not found errors



I keep getting class-not-found exceptions trying to deploy with JRUN 3.0
There is a LogonForm.class file in
servers/default/webscm/Web-Inf/classes/com/ellacoya/webwcm/logon.


Any suggestions?

don

/webscm/logon/logon.jsp:

javax.servlet.ServletException: Exception thrown processing JSP page.
javax.servlet.jsp.JspException: Exception creating bean of class
com.ellacoya.webscm.logon.LogonForm: java.lang.ClassNotFoundException:
com.ellacoya.webscm.logon.LogonForm
	at
org.apache.struts.taglib.html.FormTag.doStartTag(FormTag.java:568)
	at
jrun__logon__logon2ejsp10._jspService(jrun__logon__logon2ejsp10.java:42)
	at
allaire.jrun.jsp.HttpJSPServlet.service(../jsp/HttpJSPServlet.java:40)
	at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1013)
	at
allaire.jrun.servlet.JRunSE.runServlet(../servlet/JRunSE.java:925)
	at
allaire.jrun.servlet.JRunNamedDispatcher.forward(../servlet/JRunNamedDispatc
her.java:34)
	at allaire.jrun.jsp.JSPServlet.service(../jsp/JSPServlet.java:175)
	at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1013)
	at
allaire.jrun.servlet.JRunSE.runServlet(../servlet/JRunSE.java:925)
	at
allaire.jrun.servlet.JRunRequestDispatcher.forward(../servlet/JRunRequestDis
patcher.java:88)
	at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1131)
	at
allaire.jrun.servlet.JvmContext.dispatch(../servlet/JvmContext.java:330)
	at allaire.jrun.http.WebEndpoint.run(../http/WebEndpoint.java:107)
	at allaire.jrun.ThreadPool.run(../ThreadPool.java:272)
	at allaire.jrun.WorkerThread.run(../WorkerThread.java:75)



don zaremba
Ellacoya Networks
603 577-5544 ext-247

Mime
View raw message