I have an error and it is not obvious to me that it's a fault of me or a struts flaw. The error is as follows: javax.servlet.ServletException: Cannot find bean org.apache.struts.taglib.html.BEAN in scope null at javax.servlet.ServletException.(ServletException.java) at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:457) ... etc. In a former mail a similar error was raised and the solution given by Craig was this one: On Wed, Jan 31, 2001 at 04:04:41PM -0800, Craig R. McClanahan wrote: > TMalvos@gcre.com wrote: > > > When trying to call a JSP I receive the following message from Tomcat: > > > > javax.servlet.ServletException: Cannot find bean under name > > org.apache.struts.taglib.html.BEAN > > at > > org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:459) > > > > I checked the STRUTS distribution and did not find it. Has anyone > > encountered this before? Thanks. > > You would get this error if you tried to use one of the input field tags like > outside of an tag. > > Craig > My situation differs altough the exception is raised when the an html:input should be rendered but it _IS_ inside an html:form (here it is the error page:) ---

Error: 500

Location: /matademo/WEB-INF/jsp/main.jsp

Internal Servlet Error:
javax.servlet.ServletException: Cannot find bean org.apache.struts.taglib.html.BEAN in scope null
        at javax.servlet.ServletException.(ServletException.java
---

But. The html:form is defined in one jsp and the html:input in another one.
I have a dozen or so upload pages with the same basic functionality but with
different meta atributes, so I'm using template here, and the jsp's
containing the attribute inputs are included with template:get. I guess
that this is the source of the error but would be very sad, if struts
could not use the template inside a form. I hope I'm missing something,
please clarify what.

The jsp codes are something like this:

----------------------------------------------------- The form definition

Közgyűlés bejelentése Alapválaszték
-------------------------------------------------- The included "attrib" jsp ... ... Seems to me, that I can't use together the templates and the html:form tags. Is this normal? incze