Hey,

Has anyone run across this error before???

javax.servlet.jsp.JspException: Missing resources attribute org.apache.struts.action.MESSAGE
        at org.apache.struts.taglib.MessageTag.doStartTag(MessageTag.java:360)
        at /createCatalog.jsp._jspService(/createCatalog.jsp.java, Compiled Code)
        at com.orionserver.http.OrionHttpJspPage.service(JAX)
        at com.evermind.server.http.HttpApplication.w5(JAX)
        at com.evermind.server.http.JSPServlet.service(JAX)
        at com.evermind.server.http.d1.si(JAX, Compiled Code)
        at com.evermind.server.http.d1.forward(JAX)
        at com.evermind.server.http.ed.sp(JAX, Compiled Code)
        at com.evermind.server.http.ed.so(JAX, Compiled Code)
        at com.evermind.util.f.run(JAX, Compiled Code)

My Web.xml file looks like this:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
      "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">
<web-app>
  <!-- Action Servlet Configuration -->
  <servlet>
    <servlet-name>action</servlet-name>
    <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
    <init-param>
      <param-name>application</param-name>
      <param-value>org.apache.struts.action.ApplicationResources</param-value>
    </init-param>
    <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/action.xml</param-value>
    </init-param>
    <init-param>
      <param-name>debug</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>detail</param-name>
      <param-value>2</param-value>
    </init-param>
    <load-on-startup>2</load-on-startup>
  </servlet>

  <!-- Action Servlet Mapping -->
  <servlet-mapping>
    <servlet-name>action</servlet-name>
    <url-pattern>*.do</url-pattern>
  </servlet-mapping>

  <!-- The Welcome File List -->
  <welcome-file-list>
    <welcome-file>createCatalog.jsp</welcome-file>
  </welcome-file-list>

  <!-- Struts Tag Library Descriptor -->
  <taglib>
    <taglib-uri>/WEB-INF/struts.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/struts-logic.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
  </taglib>
 
  <!-- EJB Reference Descriptor -->
  <ejb-ref>
    <description>Responsible for calling the ProducerServices EJB</description>
    <ejb-ref-name>ejb/ProducerServicesHome</ejb-ref-name>
    <ejb-ref-type>Session</ejb-ref-type>
    <home>com.canlink.components.services.ProducerServicesHome</home>
    <remote>com.canlink.components.services.ProducerServices</remote>
  </ejb-ref>

</web-app>
 

Thanks!!!