struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (Jira)" <j...@apache.org>
Subject [jira] [Commented] (WW-5033) Update a few Struts 2.5.x libraries to more recent versions
Date Wed, 09 Oct 2019 05:25:00 GMT

    [ https://issues.apache.org/jira/browse/WW-5033?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16947370#comment-16947370
] 

ASF subversion and git services commented on WW-5033:
-----------------------------------------------------

Commit fe98223724e4d01757328d75193cf4dc675428c2 in struts's branch refs/heads/struts-2-5-x
from JCgH4164838Gh792C124B5
[ https://gitbox.apache.org/repos/asf?p=struts.git;h=fe98223 ]

Update multiple Struts 2.5.x libraries to more recent versions.
Relates to WW-5033 and PRs: #356, #362.  Updated libraries:

Spring Platform 4.3.24 -> 4.3.25
Log4j2 2.11.2 -> 2.12.1
Jackson 2.9.9 -> 2.9.10 (allows removal of jackson 2.9.9.3 "micro patch"
entry, taking care of pom.xml FIXME).
stax2-api 4.1 -> 4.2 (noted during Jackson update)
Fluido Skin 1.7 -> 1.8
SLF4J 1.7.26 -> 1.7.28


> Update a few Struts 2.5.x libraries to more recent versions
> -----------------------------------------------------------
>
>                 Key: WW-5033
>                 URL: https://issues.apache.org/jira/browse/WW-5033
>             Project: Struts 2
>          Issue Type: Dependency
>          Components: Build Management, Other
>    Affects Versions: 2.5.20
>            Reporter: James Chaplin
>            Priority: Minor
>              Labels: build, pull-request-available
>             Fix For: 2.5.21, 2.6
>
>
> Hello Apache Struts Team.
> This Jira issue is intended to track introduction of newer (compatible) library versions
for the Struts 2.5.x line.
> Please find below a list of library version updates for the 2.5.x build line, for which
the regression build completes successfully.
> ---------
> Update Struts 2.5.20 build with some newer (compatible) library versions.
> Change the main pom.xml library versions for the following:
>   - Jackson 2.9.8 -> 2.9.9
>   - Log4j2 2.11.1 -> 2.11.2
>   - OGNL 3.1.22 -> 3.1.23
> ---------
> There is an open PR #356 demonstrating the CI build completes with the above library
upgrades.
> Please review and consider for inclusion in 2.5.21.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message