struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (Jira)" <j...@apache.org>
Subject [jira] [Commented] (WW-5038) Upgrade jackson-databind to version 2.9.9.3
Date Sat, 07 Sep 2019 06:46:00 GMT

    [ https://issues.apache.org/jira/browse/WW-5038?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16924750#comment-16924750
] 

ASF subversion and git services commented on WW-5038:
-----------------------------------------------------

Commit 8187006c31f1ebdc80f4090a2e1f05c8bdc223f7 in struts's branch refs/heads/master from
Lukasz Lenart
[ https://gitbox.apache.org/repos/asf?p=struts.git;h=8187006 ]

WW-5038 Upgrades jackson-databind to version 2.9.9.3
plus upgrades jackson-core to 2.9.9


> Upgrade jackson-databind to version 2.9.9.3
> -------------------------------------------
>
>                 Key: WW-5038
>                 URL: https://issues.apache.org/jira/browse/WW-5038
>             Project: Struts 2
>          Issue Type: Dependency
>          Components: Plugin - REST
>            Reporter: Lukasz Lenart
>            Priority: Minor
>             Fix For: 2.5.21, 2.6
>
>
> One or more dependencies were identified with known vulnerabilities in Struts 2 REST
Plugin:
> jackson-databind-2.9.8.jar (cpe:/a:fasterxml:jackson:2.9.8, cpe:/a:fasterxml:jackson-databind:2.9.8,
com.fasterxml.jackson.core:jackson-databind:2.9.8) : CVE-2019-14379, CVE-2019-12814, CVE-2019-14439,
CVE-2019-12086, CVE-2019-12384



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message