struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4996) Refactor DefaultTypeConverterCreator to use ObjectFactory#buildConverter
Date Sun, 06 Jan 2019 05:58:00 GMT

    [ https://issues.apache.org/jira/browse/WW-4996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16735086#comment-16735086
] 

ASF subversion and git services commented on WW-4996:
-----------------------------------------------------

Commit 19134516d8ef338c28c08dde60a7fb413be0357c in struts's branch refs/heads/master from
Lukasz Lenart
[ https://gitbox.apache.org/repos/asf?p=struts.git;h=1913451 ]

WW-4996 Uses Struts* naming pattern instead of Default*


> Refactor DefaultTypeConverterCreator to use ObjectFactory#buildConverter
> ------------------------------------------------------------------------
>
>                 Key: WW-4996
>                 URL: https://issues.apache.org/jira/browse/WW-4996
>             Project: Struts 2
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Lukasz Lenart
>            Assignee: Lukasz Lenart
>            Priority: Minor
>             Fix For: 2.6
>
>
> Right now {{DefaultTypeConverterCreator}} doesn't use {{ObjectFactory#buildConverter()}}
method which is a bit misleading. Also the class name is misleading as this is a default Struts
implementation so it should be named {{StrutsTypeConverterCreator}}.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message