struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4994) Error when upgrading to struts2.3.35
Date Mon, 17 Dec 2018 08:13:00 GMT

    [ https://issues.apache.org/jira/browse/WW-4994?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16722770#comment-16722770
] 

Jang commented on WW-4994:
--------------------------

Hi Lukasz

We are using Java 1.5.
However, in the previous version (2.3.34), we completed the upgrade using Java 1.5.

Has 2.3.35 been modified to use only Java 1.6?

We can not upgrade the Java version right away.

Can I temporarily fix the problem?

Thanks.

> Error when upgrading to struts2.3.35
> ------------------------------------
>
>                 Key: WW-4994
>                 URL: https://issues.apache.org/jira/browse/WW-4994
>             Project: Struts 2
>          Issue Type: Bug
>          Components: &quot;New&quot; API
>    Affects Versions: 2.3.35
>            Reporter: Jang
>            Priority: Blocker
>             Fix For: 2.3.37
>
>         Attachments: error.txt
>
>
> The following error occurs.
> Please check the attached file.
>  
>  
>  <Error> <HTTP> <BEA-101165> <Could not load user defined filter
in web.xml: 
>  weblogic.servlet.internal.WebAppServletContext@1041bea - appName: '_auto_generated_ear_',
name: '/iome', context-path: '/iome' 
>  org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.
>  java.lang.ClassNotFoundException: Class bytes found but defineClass()failed for: 
>  'org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter'
>  at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:265)
>  at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:54)
>  at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>  at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
>  at weblogic.utils.classloaders.GenericClassLoader.loadClass(GenericClassLoader.java:179)
>  Truncated. see log file for complete stacktrace
>  java.lang.UnsupportedClassVersionError: Bad version number in .class file
>  at java.lang.ClassLoader.defineClass1(Native Method)
>  at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
>  at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
>  at weblogic.utils.classloaders.GenericClassLoader.defineClass(GenericClassLoader.java:338)
>  at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:291)
>  Truncated. see log file for complete stacktrace



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message