struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Chaplin (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WW-4988) Upgrade DWR from 1.x to 2.x (for DWR plugin)
Date Sat, 01 Dec 2018 14:34:00 GMT
James Chaplin created WW-4988:
---------------------------------

             Summary: Upgrade DWR from 1.x to 2.x (for DWR plugin)
                 Key: WW-4988
                 URL: https://issues.apache.org/jira/browse/WW-4988
             Project: Struts 2
          Issue Type: Dependency
          Components: Plugin - DWR
    Affects Versions: 2.6
         Environment: All environments
            Reporter: James Chaplin
             Fix For: 2.6


Hello Apache Struts Team.

There appears to be a failure/warning reported in the automated nightly Jenkins builds in
relation to the DWR plugin component (reported by org.owasp:dependency-check-maven).

A PR ([https://github.com/apache/struts/pull/283)] has been opened in hopes of addressing
this by _upgrading the Struts 2.6 DWR plugin to the most recent API-compatible version of
DWR_ (2.x series).

 

Since _only manual testing/verification is possible at this time_ (requires modification of
the showcase application web.xml, see above PR for details), _there is a risk that upgrading
the DWR dependency might introduce issues for the DWR plugin_.

 

If there is anyone who has _suggestions on creating an automated (preferably self-contained)
test for the DWR plugin_ within the regression suite please advise by commenting on this JIRA.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message