struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yasser Zamani (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4796) Rename Spring related flags to use the same pattern
Date Thu, 31 May 2018 06:43:00 GMT

    [ https://issues.apache.org/jira/browse/WW-4796?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16496177#comment-16496177
] 

Yasser Zamani commented on WW-4796:
-----------------------------------

I reviewed all {{*Constants.java}} and found almost in all places we use {{struts.\{plugin
name}.x... pattern}}. So I think inside spring plugin we should use {{struts.spring.x...}}
pattern (without {{.objectfactory.}}). That mentioned different {{struts.objectFactory.spring...}}
pattern seems good to me because it's inside {{core}} not a plugin. I also saw you're right,
both constant value and variable names could being reviewed in these java files.

> Rename Spring related flags to use the same pattern
> ---------------------------------------------------
>
>                 Key: WW-4796
>                 URL: https://issues.apache.org/jira/browse/WW-4796
>             Project: Struts 2
>          Issue Type: Improvement
>          Components: Plugin - Spring
>            Reporter: Lukasz Lenart
>            Assignee: Stefaan Dutry
>            Priority: Major
>             Fix For: 2.6
>
>
> There are two different schemas used to name those flags, {{struts.objectFactory.spring.autoWire}}
and {{struts.class.reloading.acceptClasses}} - they should be renamed to use the same schema,
i.e. {{struts.objectFactory.spring...}}
> https://cwiki.apache.org/confluence/display/WW/Spring+Plugin



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message