struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefaan Dutry (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4796) Rename Spring related flags to use the same pattern
Date Mon, 28 May 2018 11:02:00 GMT

    [ https://issues.apache.org/jira/browse/WW-4796?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16492534#comment-16492534
] 

Stefaan Dutry commented on WW-4796:
-----------------------------------

[~lukaszlenart]
The {{struts-plugin.xml}} from the {{cdi-plugin}} contains a constant from the {{spring-plugin}},
but i suspect it may just be removed from there?

{code:xml|title=plugins/cdi/src/main/resources/struts-plugin.xml}
<constant name="struts.class.reloading.reloadConfig" value="false" />
{code}

> Rename Spring related flags to use the same pattern
> ---------------------------------------------------
>
>                 Key: WW-4796
>                 URL: https://issues.apache.org/jira/browse/WW-4796
>             Project: Struts 2
>          Issue Type: Improvement
>          Components: Plugin - Spring
>            Reporter: Lukasz Lenart
>            Assignee: Stefaan Dutry
>            Priority: Major
>             Fix For: 2.6
>
>
> There are two different schemas used to name those flags, {{struts.objectFactory.spring.autoWire}}
and {{struts.class.reloading.acceptClasses}} - they should be renamed to use the same schema,
i.e. {{struts.objectFactory.spring...}}
> https://cwiki.apache.org/confluence/display/WW/Spring+Plugin



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message