struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4855) I am migrating my struts 2.2.x to 2.5.13 and where all used struts taglibs and tags UI is breaking where i have not used bootstrap there and all working fine
Date Mon, 11 Sep 2017 06:51:00 GMT

    [ https://issues.apache.org/jira/browse/WW-4855?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16160805#comment-16160805
] 

Lukasz Lenart commented on WW-4855:
-----------------------------------

Please read the migration guide [1] and if you have any other questions please subscribe to
the User Mailing list and post them there. JIRA isn't the right place to discuss your migration
issues.

[1] https://struts.apache.org/docs/struts-23-to-25-migration.html
[2] http://struts.apache.org/mail.html

> I am migrating my struts 2.2.x to 2.5.13 and where all used struts taglibs and tags UI
is breaking where i have not used bootstrap there and all working fine
> -------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: WW-4855
>                 URL: https://issues.apache.org/jira/browse/WW-4855
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Other
>    Affects Versions: 2.5.13
>         Environment: jdk 1.7, struts 2.5.13, spring2.5 
>            Reporter: Nagarjuna
>              Labels: security
>             Fix For: 2.5.14
>
>   Original Estimate: 193h
>  Remaining Estimate: 193h
>
> Do i upgrade spring also from 2.5 any other version when i am upgrading struts 2.2.x
to 2.5.13 ,
> i upgraded some dependencies also ognl 2.7.x to 3.1.15.and in web.xml filterdipatcher
to org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter upgraded. and dtd
also 2.0 to 2.5 upgraded in all struts.xml, tiles.xml .
> below are old versions used :
> struts2-spring-plugin-2.2.1.jar
> struts2-core 2.2.3
> struts2-json-plugin 2.3.4.1
> struts2-tiles-plugin 2.2.3
> and i need all should be upgraded to 2.5.13 and please help me what are  all should be
taken care. is it missing anything please its urgent migration fo rus



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message