struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4803) OGNL not working with camel case and reverting to 3.0.6 isn't working
Date Thu, 15 Jun 2017 05:34:01 GMT

    [ https://issues.apache.org/jira/browse/WW-4803?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16050014#comment-16050014
] 

Lukasz Lenart commented on WW-4803:
-----------------------------------

The simplest test is to define a field, e.g. {{private String xAxis;}} and then use your IDE
of choice to generate setter and getter, this what IntelliJ IDEA generates for me:

{code:java}
    public String getxAxis() {
        return xAxis;
    }

    public void setxAxis(String xAxis) {
        this.xAxis = xAxis;
    }
{code}

> OGNL not working with camel case and reverting to 3.0.6 isn't working
> ---------------------------------------------------------------------
>
>                 Key: WW-4803
>                 URL: https://issues.apache.org/jira/browse/WW-4803
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core Actions
>    Affects Versions: 2.3.32
>            Reporter: jade Lindquist
>
> After upgrading to Struts 2.3.32, actions with request parameters in camel case such
as xAxis and yAxis broke. Reverting to ognl-3.0.6.jar was recommended in bug WW-4616 but it
doesn't work because it throws this error:
> SEVERE: Exception starting filter struts2
> java.lang.NoSuchMethodError: ognl.SimpleNode.isSequence(Lognl/OgnlContext;)
> 		at com.opensymphony.xwork2.ognl.OgnlUtil.isEvalExpression(OgnlUtil.java:310)
> We still have lots of struts 1 code so we can't upgrade to struts 2.5. I also tried using
the ognl-3.1.12.jar from struts 2.5 but the camel case error is still there.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message