struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-3171) "double" and "Double" are not validated with the same decimal séparator
Date Tue, 16 May 2017 13:05:04 GMT

    [ https://issues.apache.org/jira/browse/WW-3171?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16012324#comment-16012324
] 

ASF GitHub Bot commented on WW-3171:
------------------------------------

Github user cnenning commented on the issue:

    https://github.com/apache/struts/pull/138
  
    > can you elaborate a bit more about parsing dates? I thought this is already supported.
    
    Now that you mention it, I see there is a locale aware `DateConverter`. Cannot remember
why we rolled our own. Might be it was not using the format (`SHORT, MEDIUM, LONG`) we wanted.
wdyt about making that configurable?



> "double" and "Double" are not validated with the same decimal séparator
> -----------------------------------------------------------------------
>
>                 Key: WW-3171
>                 URL: https://issues.apache.org/jira/browse/WW-3171
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core Actions
>    Affects Versions: 2.0.14
>         Environment: Windows or Linux - Running under Tomcat 6.0 - fr_FR
>            Reporter: françois-frédéric jean
>            Assignee: Lukasz Lenart
>            Priority: Critical
>             Fix For: 2.5.next
>
>
> I had this strange behaviour.
> I have two double in my Action (extends ActionSupport):
> ---------------------------
> private double dbl1;
> private Double dbl2;
> ---------------------------
> With there respective getters and setters.
> But, when I call the action with these two doubles (from a classical HTML form), I must
put a "dot" for the double, and a "comma" for the Double as a decimal separator, 
> I'm surprised by this behaviour .... Nothing particular was done (HTML form calling an
action). I can't imagine what is the reason of this behaviour, so I raise it as a bug.
> Regards
> Francillo



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message