struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Khurram (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4758) @autowired does not work since Struts 2.3.28.1
Date Wed, 15 Mar 2017 06:24:41 GMT

    [ https://issues.apache.org/jira/browse/WW-4758?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15925609#comment-15925609
] 

Khurram commented on WW-4758:
-----------------------------

<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-aop</artifactId>
				<version>${spring.version}</version>
			</dependency>
			<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-context</artifactId>
				<version>${spring.version}</version>
			</dependency>
			<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-context-support</artifactId>
				<version>${spring.version}</version>
			</dependency>
			<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-orm</artifactId>
				<version>${spring.version}</version>
			</dependency>
			<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-tx</artifactId>
				<version>${spring.version}</version>
			</dependency>
			<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-web</artifactId>
				<version>${spring.version}</version>
			</dependency>
			<dependency>
				<groupId>org.springframework</groupId>
				<artifactId>spring-webmvc</artifactId>
				<version>${spring.version}</version>
			</dependency>
			

> @autowired does not work since Struts 2.3.28.1 
> -----------------------------------------------
>
>                 Key: WW-4758
>                 URL: https://issues.apache.org/jira/browse/WW-4758
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Plugin - Spring
>    Affects Versions: 2.3.28
>            Reporter: Khurram
>             Fix For: 2.5.next
>
>
> I am trying to run on Tomcat a Spring 4 + Struts 2 + Hibernate web app, but it fails
to start with NullPointerException for autowired field. This issue is happening after release
of 2.3.28.1 So please help
> 2017-03-15 15:28:35,308 [http-bio-8009-exec-1] ERROR au.com.presentation.struts.action.tiles.landing.LandingSummaryPreparer
- Error Id:
> java.lang.NullPointerException
> 	at au.com.presentation.struts.action.tiles.landing.LandingSummaryPreparer.performPreparer(LandingSummaryPreparer.java:142
> and in my code I have autowired that always returning null
> @Autowired
> private Services services;



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message