struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4750) Why JSONValidationInterceptor return Status Code 400 BAD_REQUEST instead of 200 SUCCESS
Date Mon, 06 Mar 2017 12:54:32 GMT

    [ https://issues.apache.org/jira/browse/WW-4750?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15897219#comment-15897219
] 

Lukasz Lenart commented on WW-4750:
-----------------------------------

It isn't a jQuery issue.

And regarding your explanation, you assume that there is a user that can read and understand
the message, but what if the client isn't a human? what's the difference between "200 valid"
and "200 invalid" then? and what's the difference between a server and an app running on it?
when you deploy your app using a cloud, there is no the server, the same for self-hosted apps
- from a client perspective there is no difference if "400" was posted by a server or by an
app.

{noformat}
10.4.1 400 Bad Request

The request could not be understood by the server due to malformed syntax. The client SHOULD
NOT repeat the request without modifications.
{noformat}


> Why JSONValidationInterceptor return Status Code 400 BAD_REQUEST instead of 200 SUCCESS
> ---------------------------------------------------------------------------------------
>
>                 Key: WW-4750
>                 URL: https://issues.apache.org/jira/browse/WW-4750
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Plugin - JSON
>    Affects Versions: 2.5.10
>         Environment: Jdk 1.7, Windows 10, jQuery 1.7.2
>            Reporter: COMBEAU
>            Priority: Minor
>              Labels: docuentation, json, validation
>             Fix For: 2.5.next
>
>         Attachments: Issue in jQuery 1.7.2.png
>
>
> Since I have made the upgrade of my Struts 2.5.8 to 2.5.10, all my POST Ajax call via
jQuery with the parameter "struts.enableJSONValidation=true" return status code 400 Bad Request
when my validation on server side is wrong. 
> And I have an issue in the caller jQuery.
> {quote}
> Failed to load resource: the server responded with a status of 400 (Bad Request)
> {quote}
> Before in 2.5.8 and all previous versions the status code was 200.
> What is the reason of this changes because jQuery doesn't understand this and it's problematic.
I see this [WW-4728|https://issues.apache.org/jira/browse/WW-4728] but in this bug it was
not mention that the status code has to be changed.
> Please provide example in the documentation if the reason of the change is a specific
reason 
> Thank you in advance for your help.
> Best regards,



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message