struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim deVos (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WW-4708) struts2-archetype-blank not found for struts v2.5.5
Date Tue, 01 Nov 2016 21:45:58 GMT
Jim deVos created WW-4708:
-----------------------------

             Summary: struts2-archetype-blank not found for struts  v2.5.5
                 Key: WW-4708
                 URL: https://issues.apache.org/jira/browse/WW-4708
             Project: Struts 2
          Issue Type: Bug
    Affects Versions: 2.5.5
            Reporter: Jim deVos


Following the steps in the [developer guide|https://struts.apache.org/docs/struts-2-maven-archetypes.html],
 I tried to generate the "blank" sample app using the archetype catalog,  but I receive an
error when choosing any of the options.  


For example, when I run the following command: 
{code}
mvn archetype:generate -DarchetypeCatalog=http://struts.apache.org/
{code}

I get a list of archetypes, as expected.
{quote}
Choose archetype:
1: http://struts.apache.org/ -> org.apache.struts:struts2-archetype-blank (Struts 2 Archetypes
- Blank)
2: http://struts.apache.org/ -> org.apache.struts:struts2-archetype-convention (Struts
2 Archetypes - Blank Convention)
3: http://struts.apache.org/ -> org.apache.struts:struts2-archetype-dbportlet (Struts 2
Archetypes - Database Portlet)
4: http://struts.apache.org/ -> org.apache.struts:struts2-archetype-plugin (Struts 2 Archetypes
- Plugin)
5: http://struts.apache.org/ -> org.apache.struts:struts2-archetype-portlet (Struts 2 Archetypes
- Portlet)
6: http://struts.apache.org/ -> org.apache.struts:struts2-archetype-starter (Struts 2 Archetypes
- Starter)
Choose a number or apply filter (format: [groupId:]artifactId, case sensitive contains): :

{quote}

However, when choosing any of the options (e.g. the "blank" webapp),  I get the following
response:

{code}
Downloading: https://repository.apache.org/content/groups/public/org/apache/struts/struts2-archetype-blank/2.5.5/struts2-archetype-blank-2.5.5.jar
Downloading: https://repo.maven.apache.org/maven2/org/apache/struts/struts2-archetype-blank/2.5.5/struts2-archetype-blank-2.5.5.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 29.977 s
[INFO] Finished at: 2016-11-01T14:22:59-07:00
[INFO] Final Memory: 17M/305M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.3:generate
(default-cli) on project standalone-pom: The desired archetype does not exist (org.apache.struts:struts2-archetype-blank:2.5.5)
-> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
{code}

The archtype:generate goal does work when I specify v2.5.1 instead. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message