struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "COMBEAU (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4684) No set parameter value to action
Date Fri, 02 Sep 2016 11:03:20 GMT

    [ https://issues.apache.org/jira/browse/WW-4684?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15458226#comment-15458226
] 

COMBEAU commented on WW-4684:
-----------------------------

Yes I am using the latest JARs from 2.5.2.

I used maven dependencies.

I think the problem is in my stack because I have this :
<interceptor-ref name="json">
<param name="contentType">application/json</param>
</interceptor-ref>

and it should be :
<interceptor-ref name="json">
<param name="accept">application/json</param>
</interceptor-ref>

But If I used "accept" I got this error :
11:01:40 ERROR [com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor.doLog] - Input
string is not well formed JSON (invalid char ï¿¿)
org.apache.struts2.json.JSONException: Input string is not well formed JSON (invalid char
ï¿¿)

> No set parameter value to action
> --------------------------------
>
>                 Key: WW-4684
>                 URL: https://issues.apache.org/jira/browse/WW-4684
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core Actions
>    Affects Versions: 2.5.2
>         Environment: Windows
>            Reporter: COMBEAU
>             Fix For: 2.5.3
>
>         Attachments: ActionSample.java, struts.xml
>
>
> I have an issue on my webapp since I have update Struts 2 to version 2.5.2 from 2.3.28.
> When I post a form with parameters via ajax call, on the action class setters are not
called. All the time the setter and getter return "null" value
> I used Struts2-core and struts2-json-plugin



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message