struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4638) TestNG 6.9.10 dependency error
Date Tue, 07 Jun 2016 07:50:21 GMT

    [ https://issues.apache.org/jira/browse/WW-4638?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15318073#comment-15318073
] 

ASF GitHub Bot commented on WW-4638:
------------------------------------

Github user victorsosa commented on the issue:

    https://github.com/apache/struts/pull/98
  
    On my end.
    
    [INFO] Installing /home/vns/workspace/struts/plugins/testng/target/struts2-testng-plugin-2.5.1-SNAPSHOT-sources.jar
to /home/vns/.m2/repository/org/apache/struts/struts2-testng-plugin/2.5.1-SNAPSHOT/struts2-testng-plugin-2.5.1-SNAPSHOT-sources.jar
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD SUCCESS
    
    also in the build was success: https://builds.apache.org/job/Struts-JDK7-pull-request/180/org.apache.struts$struts2-testng-plugin/
    
    Yes, I updated the fork from master. Sorry about the update. the only file changed is
the pom.xml.


> TestNG 6.9.10 dependency error
> ------------------------------
>
>                 Key: WW-4638
>                 URL: https://issues.apache.org/jira/browse/WW-4638
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Plugin - TestNG
>    Affects Versions: 2.3.28, 2.5
>            Reporter: Jon Juaristi
>             Fix For: 2.3.29, 2.5.1
>
>
> When trying to add the TestNG plugin as a dependency with TestNG 6.9.10 in Gradle, the
test compilation fails.
> The output for these dependencies
> {code}
> testCompile 'org.assertj:assertj-core:2.4.1'
> testCompile 'org.testng:testng:6.9.10'
> testCompile 'org.apache.struts:struts2-testng-plugin:2.3.28.1'
> //or testCompile 'org.apache.struts:struts2-testng-plugin:2.5'
> {code}
> Is the next one
> {code}
> FAILURE: Build failed with an exception.
> * What went wrong:
> Could not resolve all dependencies for configuration ':testCompileClasspath'.
> > Could not find testng-jdk15.jar (org.testng:testng:6.9.10).
>   Searched in the following locations:
>       https://repo1.maven.org/maven2/org/testng/testng/6.9.10/testng-6.9.10-jdk15.jar
> {code}
> The same happens for JCenter.
> It searches a file that doesn't exist, from what I've read the last version with jdk15.jar
is something like 4.4.7, if I'm not mistaken.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message