struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jon Y. (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WW-4541) xwork-core (> 2.3.20) has a dependency to commons-lang3 (3.2) which is problematic with Java 5
Date Tue, 01 Sep 2015 13:29:45 GMT
Jon Y. created WW-4541:
--------------------------

             Summary: xwork-core (> 2.3.20) has a dependency to commons-lang3 (3.2) which
is problematic with Java 5
                 Key: WW-4541
                 URL: https://issues.apache.org/jira/browse/WW-4541
             Project: Struts 2
          Issue Type: Bug
    Affects Versions: 2.3.20
         Environment: JAVA 5
            Reporter: Jon Y.


Since the xwork-core version 2.3.20 there is a dependency to commons-lang3 version 3.2 which
is defined in the struts2-parent POM file.
But according to [1] commons-lang3 3.2 requires at least Java 6. Strictly speaking, Struts
2 versions higher than 2.3.20 needs Java 6.
If you have a web project based on Java 5 and the commons-lang3 library is used, you will
get a compile error.
"class file has wrong version 50.0, should be 49.0"

[1] https://commons.apache.org/proper/commons-lang/release-history.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message