struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (WW-4481) Deprecated warning gives no context
Date Fri, 03 Apr 2015 05:13:53 GMT

     [ https://issues.apache.org/jira/browse/WW-4481?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lukasz Lenart updated WW-4481:
------------------------------
    Affects Version/s:     (was: 2.3.22)
                       2.3.23

> Deprecated warning gives no context
> -----------------------------------
>
>                 Key: WW-4481
>                 URL: https://issues.apache.org/jira/browse/WW-4481
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Value Stack
>    Affects Versions: 2.3.23
>            Reporter: Jasper Rosenberg
>            Assignee: Lukasz Lenart
>            Priority: Critical
>             Fix For: 2.3.23
>
>
> I released 2.3.22 and immediately had my log files fill up with this warning:
> WARN  [SecurityMemberAccess] Support for accessing static methods is deprecated! Please
refactor your application!
> I was surprised because I thought I had actually removed all static references, but I
can't find what I missed because this warning has no context.  Can you please add the information
about the expression being evaluated so I can track down the usage?  Thanks.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message