struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabrice Cannizzaro (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WW-4435) CXF broken with upgrade of ASM 5 since Struts 2.3.20
Date Thu, 18 Dec 2014 14:58:13 GMT
Fabrice Cannizzaro created WW-4435:
--------------------------------------

             Summary: CXF broken with upgrade of ASM 5 since Struts 2.3.20
                 Key: WW-4435
                 URL: https://issues.apache.org/jira/browse/WW-4435
             Project: Struts 2
          Issue Type: Bug
          Components: Integration
    Affects Versions: 2.3.20
            Reporter: Fabrice Cannizzaro


Hi,

Since upgrade of Struts in 2.3.20, the version of ASM has been upgraded to 5.0.2.

Actually, I use CXF with Struts 2.

The problem is CXF uses ASM 3.x and it's not compatible with the new API of ASM 5.0.2. All
interfaces *Visitor.java have been replaced with abstract classes and the class "WrapperClassGenerator"
in CXF is broken because it uses the interfaces "AnnotationVisitor", "FieldVisitor" and "MethodVisitor".

Why do you upgrade ASM 3.3 to ASM 5.0.2 (four years between the two versions!) with this patch
of Struts 2 (2.3.20)?

Is there a workaround?

Thank you in advance.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message