struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johannes Geppert (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (WW-4418) Plugin script resources don't load when action extension is blank
Date Thu, 13 Nov 2014 08:21:34 GMT

    [ https://issues.apache.org/jira/browse/WW-4418?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14209479#comment-14209479
] 

Johannes Geppert edited comment on WW-4418 at 11/13/14 8:20 AM:
----------------------------------------------------------------

Like you see it works well for the Struts2 jquery Showcase.
http://struts.jgeppert.com/struts2-jquery-showcase/struts/utils.js

How looks your filter settings in the web.xml?


was (Author: jogep):
Like you see it works well for the Struts2 jquery Showcase.
http://struts.jgeppert.com/struts2-jquery-showcase/struts/utils.js

How looks your filter filter settings in theweb.xml?

> Plugin script resources don't load when action extension is blank
> -----------------------------------------------------------------
>
>                 Key: WW-4418
>                 URL: https://issues.apache.org/jira/browse/WW-4418
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core Actions
>    Affects Versions: 2.1.8
>            Reporter: Paul Benedict
>            Priority: Minor
>             Fix For: 2.5
>
>
> Using <s:head> outputs a link to utils.js:
> {code}
> <script src="/mycontext/struts/utils.js"...></script>
> {code}
> But the file can't be found. FYI, I have no action extension. The solution is to make
the action extension a comma:
> http://stackoverflow.com/questions/12607075/struts2-action-extension-causing-css-javascript-and-struts-dojo-to-break
> But this is obviously a bug.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message