struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (WW-3382) Struts 2.1.8.1 s:a tags are not rendering link text
Date Fri, 11 Apr 2014 14:41:20 GMT

     [ https://issues.apache.org/jira/browse/WW-3382?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lukasz Lenart closed WW-3382.
-----------------------------

    Resolution: Not a Problem

I don't see any problem, please reopen and post some example code if disagree

> Struts 2.1.8.1 s:a tags are not rendering link text
> ---------------------------------------------------
>
>                 Key: WW-3382
>                 URL: https://issues.apache.org/jira/browse/WW-3382
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Plugin - Tags
>    Affects Versions: 2.1.8, 2.1.8.1
>            Reporter: Nikola Zifra
>              Labels: 2181, link, missing, struts, text
>             Fix For: 2.3.18
>
>
> Hi in one  of our companies older projects I am trying to replace existing Struts 2.0.9
with Struts 2.1.8.1. Project uses Maven 2 as build tool and embedded Jetty 6.1.22 through
maven jetty plugin. The first problem I encountered is that s:a tags which have used to work
normally with Struts 2.0.9 and were generating <a href='URL'>Some link text</a>
as output are now generating just <a href='URL'> </a> without any link text. This
applies both to Struts 2.1.8.1 and Struts 2.1.8. I tried also servlet-api-2.4 and servlet-api-2.5
as runtime dependency for maven jetty plugin but <a href='URL'> </a> HTML tags
were still being generated. However when i switched to Struts 2.1.6 <a href='URL'>Some
link text</a> started appearing in generated HTML. Could someone pls. investigate is
this a bug or intended behavior of Struts 2.1.8.1.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message