struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (WW-3938) s:include problem with hrml comment <!-- -->
Date Wed, 16 Oct 2013 13:21:42 GMT

    [ https://issues.apache.org/jira/browse/WW-3938?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13796771#comment-13796771
] 

Lukasz Lenart edited comment on WW-3938 at 10/16/13 1:19 PM:
-------------------------------------------------------------

Do you use {{<%@ page language="java" contentType="text/html; charset=UTF-8" pageEncoding="UTF-8"%>}}
in each JSP page?


was (Author: lukaszlenart):
Do you use {{<%@page pageEncoding="UTF-8" %>}} in each JSP page?

> s:include problem with hrml comment <!-- -->
> --------------------------------------------
>
>                 Key: WW-3938
>                 URL: https://issues.apache.org/jira/browse/WW-3938
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Other
>    Affects Versions: 2.3.7
>            Reporter: Rsorrt
>            Priority: Critical
>              Labels: features
>             Fix For: 2.3.16
>
>
> in my layout.jsp I have
> <html>
> <head>
> <s:include value="../include/pippo.jsp" />
> </head>
> if, in pippo.jsp I have an HTML comment with include a character with accent è|ì|ò|à
then result html code is missing the "-->" 
> Example pippo.jsp
> --------------------------
> <!-- è -->
> --------------------------
> The resulting HTML is 
> --------------------------
> <!-- 
> </head>
> --------------------------
> Is missing the "-->" part of the comment so all the rest is like included in a comment.
> The previous version of struts2 was not doing it.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message