struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitri (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-3861) Using namespace in Portlet URLs does not work anymore
Date Fri, 11 Oct 2013 16:26:42 GMT

    [ https://issues.apache.org/jira/browse/WW-3861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13792766#comment-13792766
] 

Dmitri commented on WW-3861:
----------------------------

I think the problem is in PortletUrlHelper.buildUrl line 95, calling prependNamespace(namespace,
portletMode, false); flag boolean for namespace is always false.  

> Using namespace in Portlet URLs does not work anymore
> -----------------------------------------------------
>
>                 Key: WW-3861
>                 URL: https://issues.apache.org/jira/browse/WW-3861
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Plugin - Portlet
>    Affects Versions: 2.3.4
>         Environment: GateIn 3.2
>            Reporter: Thomas Delhoménie
>             Fix For: 2.3.17
>
>         Attachments: WW-3861.patch
>
>
> I just tried the sample portlet apps (http://svn.apache.org/viewvc/struts/struts2/trunk/apps/portlet/).
> The link example using a namespace (edit mode -> dummy test) does not work anymore
(it used to work in 2.3.3).
> The namespace returned by the org.apache.struts2.portlet.util.PortletUrlHelper.buildUrl
method does not prepend the portlet mode in this case ("/dummy" instead of "/edit/dummy").



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message