struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rene Gielen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4178) Question on the Support for Struts2-Struts1 plugin
Date Thu, 15 Aug 2013 10:45:49 GMT

    [ https://issues.apache.org/jira/browse/WW-4178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13740857#comment-13740857
] 

Rene Gielen commented on WW-4178:
---------------------------------

Vijay,

to get support for usage and best practices regarding the Struts 2 to Struts 1 bridge plugin,
please ask your questions on the user mailing list. See http://struts.apache.org/mail.html
on how it works and how to subscribe.

As for the JSP issue, the broken link references this ticket: https://issues.apache.org/jira/browse/WW-2157.
Most likely there will be no further efforts to fix this from the Struts committers. If you
want to discuss this issue or maybe want to contribute, please ask your questions on the Struts
developer list as found as well in the first provided link.

Anyway, please make sure that your are basing your development on Struts >= 2.3.15.1, since
all previous versions contain several critical security vulnerabilities. Ensure to have consistent
versioning among all Struts 2 libraries used in your project. That is, use at least struts2-struts1-plugin-2.3.15.1.jar
along with Struts 2 libraries matching the same version.
                
> Question on the Support for Struts2-Struts1 plugin
> --------------------------------------------------
>
>                 Key: WW-4178
>                 URL: https://issues.apache.org/jira/browse/WW-4178
>             Project: Struts 2
>          Issue Type: Temp
>          Components: Other
>    Affects Versions: 2.3.15.1
>            Reporter: Vijayalayan Selvaraj
>            Assignee: Rene Gielen
>            Priority: Minor
>
> Hi, Sincere Apologies for raising this issue Here. I'm not aware of the process and not
sure if I am raising this in the correct forum. 
> Our project is developed on Struts 1.1 and has been running without any issues for the
past 5-8 years. As per the recent announcement of EOL for struts 1.x, we are planning to move
to Struts 2. As per the migration strategies stated, We are planning to use struts2-struts1-plugin-2.1.8.1.jar
in our systems and for any new development we are planning to use Struts 2 framework. 
> With regard to this, we have the following Queries.
> If we were using this plugin and as stated in the plugin documentations, struts1 jar
will still needs to be maintained in order to function  correctly, Will there be a scenario
of support for this plugin is required, Can we expect any fix from apache to address the issue
on the plugin or struts1 jar files.
> As stated in the website (http://struts.apache.org/development/2.x/docs/struts-1-plugin.html),I'm
not able to see the ticket specified for continued use of struts 1 tag libraries in jsps.
Can you please share some information about the latest status on this JIRA ticket.
> Also it will be good, if there are any readily available migration tools from Struts1
to Struts2 for JSPs or Java servlets source code. 
> Once again apologies for raising this in the forum.
> Many thanks in advance for your help.
> Regards,
> Vijay.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message