struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rene Gielen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4016) Rename validatorType to validatorName
Date Mon, 18 Mar 2013 23:31:15 GMT

    [ https://issues.apache.org/jira/browse/WW-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13605797#comment-13605797
] 

Rene Gielen commented on WW-4016:
---------------------------------

As a really breaking change, 3.0 target version looks fine
                
> Rename validatorType to validatorName
> -------------------------------------
>
>                 Key: WW-4016
>                 URL: https://issues.apache.org/jira/browse/WW-4016
>             Project: Struts 2
>          Issue Type: Improvement
>          Components: XML Validators
>    Affects Versions: 2.3.12
>            Reporter: Lukasz Lenart
>            Priority: Minor
>             Fix For: 3.0
>
>         Attachments: WW-4016.patch
>
>
> Right no validatorType is a simple String in AnnotationValidationConfigurationBuilder
which can lead to mistakes.
> {code:java}
> String validatorType = "regex";
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message