struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Laruelle (JIRA) <j...@apache.org>
Subject [jira] Commented: (STR-3102) Form data lost due using multipart encryption
Date Wed, 04 Jun 2008 12:34:06 GMT

    [ https://issues.apache.org/struts/browse/STR-3102?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=44014#action_44014
] 

Cédric Laruelle commented on STR-3102:
--------------------------------------

Did you find anything on this subject ? Actually, I have the very same problem using Tomcat
6.0.16 on Windows XP and Centos5 (reproducted on both) and Spring 2.5.1.
It seems to happen on the field on which tomcat internal cuts the received data when reading
into an internal buffer.

> Form data lost due using multipart encryption
> ---------------------------------------------
>
>                 Key: STR-3102
>                 URL: https://issues.apache.org/struts/browse/STR-3102
>             Project: Struts 1
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.3.8
>         Environment: Redhat Enterprise 5, Tomcat 5.028, !E7 browser.
>            Reporter: Ismael Fal
>
> When submitting a form using multipart encryption, enctype="multipart/form-data", request
data for a form bean (specifically, a vector of custom objects) is lost.  In a vector of 60
objects, one field from one object was lost, seemingly arbitrary.  When multipart encryption
is turned off, the data passes in the request as expected.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message