struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Builds
Date Thu, 13 Feb 2020 06:23:39 GMT
I think this is not the case, I just notice that Jenkins maps
container path to the same host path as $WORKSPACE, that's why that
path isn't /root/.m2/...

Checking one more idea

śr., 12 lut 2020 o 20:44 Yasser Zamani <yasserzamani@apache.org> napisał(a):
>
> Thank you!
>
> Yeah it seems that ClassLoader.getResources("") might return URIs in
> format "classpath?filePosition" [1]. I think we should decouple from
> underlying JDK via using uri.openConnection instead of new File(uri) at
> our ClassPathFinder.
>
> Regards.
>
>
> [1]
> https://github.com/junit-team/junit5/blob/42ea2f530c9de5467714fcaf605052664bb8b131/junit-platform-engine/src/main/java/org/junit/platform/engine/support/descriptor/ClasspathResourceSource.java#L100
>
> On 2/12/2020 10:38 PM, Lukasz Lenart wrote:
> > Yasser,
> >
> > your change showed this
> >
> > [ERROR] testIncludeWithWildcard(com.opensymphony.xwork2.config.providers.XmlConfigurationProviderTest)
> >  Time elapsed: 0.021 s  <<< ERROR!
> > com.opensymphony.xwork2.config.ConfigurationException: Error loading
> > configuration file
> > com/opensymphony/xwork2/config/providers/xwork-test-include-wildcard.xml
> > at com.opensymphony.xwork2.config.providers.XmlConfigurationProviderTest.testIncludeWithWildcard(XmlConfigurationProviderTest.java:297)
> > Caused by: org.apache.struts2.StrutsException: Currently URI with
> > query component isn't supported:
> > file:/home/jenkins/jenkins-slave/workspace/Apache_Struts_PR-394/?/.m2/repository/org/apache/maven/surefire/surefire-junit47/2.22.2/surefire-junit47-2.22.2.jar
> > at com.opensymphony.xwork2.config.providers.XmlConfigurationProviderTest.testIncludeWithWildcard(XmlConfigurationProviderTest.java:297)
> >
> > https://builds.apache.org/view/S-Z/view/Struts/job/Apache%20Struts/view/change-requests/job/PR-394/34/consoleFull
> >
> > There is "?" instead of just nothing, no idea what's wrong
> >
> >
> > Regards
> >

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message