struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yasser Zamani <yasserzam...@apache.org>
Subject Re: Testing Results
Date Thu, 27 Dec 2018 16:38:54 GMT
Hi Louis,

Thanks for your log! Yes Struts already has manipulated to work with
java 9 and 11. Struts 2.5.19 and 2.6 are anticipated to work without any
user further configuration [1].

Thanks for using Struts.

Regards.

[1] https://travis-ci.org/apache/struts/branches

On 12/27/2018 7:30 PM, Louis Smith wrote:
> Sirs:
> 
> I have been testing moving my apps to Wildfly 15 running under OpenJDK11.
> I used 11 to re-build one of my legacy struts 2 applications, using
> 
> <struts.version>2.5.16</struts.version>
> <tiles.version>3.0.8</tiles.version>
> 
> 
> The application built, deployed - and the APIs ran, but no struts action
> would map.  All threw the no mapping for namespace "/" and action named
> <whatever>
> 
> I traced it to ASM in convention plugin, and fixed it via:
> 
> <dependency>
>     <groupId>org.ow2.asm</groupId>
>     <artifactId>asm</artifactId>
>     <version>7.0</version>
> </dependency>
> <dependency>
>     <groupId>org.ow2.asm</groupId>
>     <artifactId>asm-commons</artifactId>
>     <version>7.0</version>
> </dependency>
> <dependency>
>     <groupId>org.apache.struts</groupId>
>     <artifactId>struts2-core</artifactId>
>     <version>${struts.version}</version>
> </dependency>
> 
> <dependency>
>     <groupId>org.apache.struts</groupId>
>     <artifactId>struts2-convention-plugin</artifactId>
>     <version>${struts.version}</version>
>     <exclusions>
>         <exclusion>
>             <groupId>org.ow2.asm</groupId>
>             <artifactId>asm</artifactId>
>         </exclusion>
>         <exclusion>
>             <groupId>org.ow2.asm</groupId>
>             <artifactId>asm-commons</artifactId>
>         </exclusion>
>     </exclusions>
> </dependency>
> 
> 
> Once this was done, the application worked again.
> 
> Louis
> 
Mime
View raw message