struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Regression in Struts 2.5.18
Date Mon, 22 Oct 2018 18:36:37 GMT
False alarm, now it works and I'm confused :\

niedz., 21 paź 2018 o 13:17 Greg Huber <gregh3269@gmail.com> napisał(a):
>
> Maybe its somewhere in locatableProperties?
>
> I change the dev to false in the war build, so I know its always off.
>
> <execution>
>                                 <id>update-struts</id>
>                                 <phase>process-resources</phase>
>                                 <configuration>
>                                     <target name="struts-update">
>                                         <echo level="info">Update
> struts.properties dev runtime to false</echo>
>                                         <replace
> dir="${project.build.directory}/classes">
>                                             <include
> name="struts.properties" />
>                                             <replacefilter
> token="struts.devMode=true" value="struts.devMode=false" />
>                                             <replacefilter
> token="struts.configuration.xml.reload=true"
> value="struts.configuration.xml.reload=false" />
>                                             <replacefilter
> token="struts.i18n.reload=true" value="struts.i18n.reload=false" />
>                                         </replace>
>                                         <property prefix="check"
> file="${project.build.directory}/classes/struts.properties" />
>                                         <echo>
>
> struts.devMode=${check.struts.devMode}
>                                         </echo>
>                                     </target>
>                                 </configuration>
>                                 <goals>
>                                     <goal>run</goal>
>                                 </goals>
>                             </execution>
>
> .....the gruff guest login does not work ;-) >> Cannot login!
>
>
>
> On Sat, 20 Oct 2018 at 13:08, Lukasz Lenart <lukaszlenart@apache.org> wrote:
>
> > pt., 19 paź 2018 o 10:24 Greg Huber <gregh3269@gmail.com> napisał(a):
> > >
> > > I remember years ago there was a bug on the reloading and fixed by
> > checking
> > > to reload once per request.
> > > (This is definitely not happening now as I always run dev reloading, it
> > > really slows things down.)
> >
> > You meant that we should reload once per request? Tie this cycle to the
> > request?
> >
> > > Where is GruufConfigurationProvider?
> >
> > I used it inside my prototype app
> >
> > https://github.com/lukaszlenart/gruuf-webapp/blob/master/src/main/java/com/gruuf/web/GruufConfigurationProvider.java
> >
> >
> > Regards
> > --
> > Łukasz
> > + 48 606 323 122 http://www.lenart.org.pl/
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> > For additional commands, e-mail: dev-help@struts.apache.org
> >
> >

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message