struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Struts 2.4
Date Tue, 08 May 2018 08:05:45 GMT
I was referring to Jackson library, which uses Java 7 now and I'm not
able to port this fix to Struts 2.3.x
https://cwiki.apache.org/confluence/display/WW/S2-054

2018-05-08 9:08 GMT+02:00 Yasser Zamani <yasserzamani@apache.org>:
>
>
> On 5/8/2018 11:16 AM, Lukasz Lenart wrote:
>> I'm working on a new release of Struts 2.3.x but it will be the last
>> release from this branch, it's very hard to keep support especially
>> using Java 6 and old dependencies.
>
> I thought I should say that I had found that recent difficulties with
> building support-2-3 branch was started after "WW-4844 Upgrades to
> struts-master 11" [1] which increases some fundamental common
> dependencies (e.g. maven compiler plugin) versions. I mean if it's
> possible to not increase struts-master version (and maybe other
> dependencies) then maybe it's possible to keep this support if it's
> required.
>
> May I ask what happens with 2-4 branch? I ask because there are commits
> on it which I would like to know if they need reviews or migration to 2-3.
>
> Regards.
>
> [1]
> https://github.com/apache/struts/commit/f11ac901d3074111db05239b15dac0dd44ede5bb

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message