struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Support for actors/asynchronous request handling
Date Mon, 23 Oct 2017 09:28:33 GMT
2017-10-22 10:08 GMT+02:00 info@flyingfischer.ch <info@flyingfischer.ch>:
> Servlet API 3.0 is needs Java 6. As far as I remember Struts minimal
> requirements are also Java 6. I do not see anything hindering us in
> upgrading Struts officially to Servlet API 3.0?

This isn't a case with Java 7 but rather how many users are still
using Servlet containers running Servlet API 2.4 - switching to
Servlet API 3.0 requires not only migrate an app but the whole
container as well.

> Am I wrong? Would this need a considerable rework of Struts? If not, I
> feel we definitively should upgrade.
>
> Will Struts be able to cope with http2? Does it already or what needs to
> be adapted?

It's a container duty in this case, I don't think we need to worry too much.


Regards
-- 
Ɓukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message