struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: s2 and jdk9: works with newer snapshot builds
Date Mon, 14 Aug 2017 18:15:35 GMT
2017-08-14 17:04 GMT+02:00 Christoph Nenning <Christoph.Nenning@lex-com.net>:
> Hi,
>
> I get different issues :(
>
> Here is my setup:
>
>
> Apache Maven 3.3.9 (NON-CANONICAL_2016-07-01T11:53:38Z_mockbuild;
> 2016-07-01T13:53:38+02:00)
> Maven home: /usr/share/maven
> Java version: 9, vendor: Oracle Corporation
> Java home: /home/test/tools/jdk-9+181
> Default locale: en_GB, platform encoding: UTF-8
> OS name: "linux", version: "4.11.12-200.fc25.x86_64", arch: "amd64",
> family: "unix"

As far I know Maven 3.5.0 is the one that has to be used with JDK9

> At first I got weird ClassNotFoundErrors and nearly all tests failed.
> After updating maven-surefire-plugin to 2.20 many tests are working. The
> ones that still fail try to load resoures by ClassLoader but with java 9
> we don't get hold of an URLClassLoader anymore and resources are not
> found.
>
> The ClassLoader type is: jdk.internal.loader.ClassLoaders$AppClassLoader

Please try this (a hint from builds@a.o):

<profile>
    <id>jdk9</id>
    <properties>
        <addmod>--add-modules java.activation --add-modules
java.xml.bind</addmod>
    </properties>
</profile>


Regards
-- 
Ɓukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message