struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Struts 2.5.11 not serving iclass icons
Date Thu, 06 Jul 2017 06:16:59 GMT
Argh... forgot to add a CSS stylesheet and now everything works as
expected, my setup below:

<%@ page contentType="text/html; charset=UTF-8" %>
<%@ taglib prefix="s" uri="/struts-tags" %>
<html>
<head>
    <title>Action Chaining</title>
    <link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css"
rel="stylesheet" media="all">
    <link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css"
rel="stylesheet"
integrity="sha384-wvfXpqpZZVQGK6TAh5PVlGOfQNHSoD2xbE+QkPxCAFlNEevoEH3Sl0sibVcOQVnN"
crossorigin="anonymous">
    <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js"
type="application/javascript"></script>
</head>

<body>

<ul>
    <li>
        <i class="fa icon-envelope"></i> <!-- does not work -->
    </li>
    <li>
        <i class="fa">&#xf003;</i> <!-- works -->
    </li>
    <li>
        <i class="fa fa-envelope-o"></i> <!-- works -->
    </li>
</ul>

<s:a action="actionA">Action A</s:a>

</body>
</html>

2017-07-06 8:12 GMT+02:00 Lukasz Lenart <lukaszlenart@apache.org>:
> I was able confirm this somehow ... but I need your exact setup, what
> version of Bootstrap do you use? Do you use FontAwesome directly?
>
> There is no issue when I used a pure reference to FontAwesome (with
> their CDN) but it doesn't work when using Bootstrap one.
>
>
> Regards
> --
> Ɓukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> 2017-07-05 14:05 GMT+02:00 info@flyingfischer.ch <info@flyingfischer.ch>:
>> Am 05.07.2017 um 13:23 schrieb Lukasz Lenart:
>>> This is very strange ... I don't understand where is the problem :\ Do
>>> you serve those CSSs files via the Strust filter as a static content?
>>>
>>
>> The CSS file seems to get through. The Layout is as should. The CSS file
>> is packed in a subdirectory of WebContent.
>>
>> Nothing has been changed between 2.5.10.1 and 2.5.11. But do not mind
>> too much, if I have two working options:
>>
>> The following works:
>>
>> <i class="fa icon-envelope"></i>
>> <i class="fa">&#xf003;</i>
>>
>> The following does not work since 2.5.11:
>>
>> <i class="fa fa-envelope-o"></i>
>>
>> web.xml
>>
>>   <listener>
>>
>> <listener-class>org.apache.struts2.tiles.StrutsTilesListener</listener-class>
>>   </listener>
>>
>>   <filter>
>>       <filter-name>struts2</filter-name>
>>
>> <filter-class>org.apache.struts2.dispatcher.filter.StrutsPrepareAndExecuteFilter</filter-class>
>>   </filter>
>>
>>   <filter-mapping>
>>     <filter-name>struts2</filter-name>
>>     <url-pattern>/*</url-pattern>
>>   </filter-mapping>
>>
>> struts.xml
>>
>> <constant name="struts.action.extension" value=","/>
>>
>> Markus
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> For additional commands, e-mail: dev-help@struts.apache.org
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message