struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "info@flyingfischer.ch" <i...@flyingfischer.ch>
Subject Re: Struts 2.5.11 not serving iclass icons
Date Wed, 05 Jul 2017 12:05:32 GMT
Am 05.07.2017 um 13:23 schrieb Lukasz Lenart:
> This is very strange ... I don't understand where is the problem :\ Do
> you serve those CSSs files via the Strust filter as a static content?
>

The CSS file seems to get through. The Layout is as should. The CSS file
is packed in a subdirectory of WebContent.

Nothing has been changed between 2.5.10.1 and 2.5.11. But do not mind
too much, if I have two working options:

The following works:

<i class="fa icon-envelope"></i>
<i class="fa">&#xf003;</i>

The following does not work since 2.5.11:

<i class="fa fa-envelope-o"></i>

web.xml

  <listener>
   
<listener-class>org.apache.struts2.tiles.StrutsTilesListener</listener-class>
  </listener>
 
  <filter>
      <filter-name>struts2</filter-name>
     
<filter-class>org.apache.struts2.dispatcher.filter.StrutsPrepareAndExecuteFilter</filter-class>
  </filter>

  <filter-mapping>
    <filter-name>struts2</filter-name>
    <url-pattern>/*</url-pattern>
  </filter-mapping>

struts.xml

<constant name="struts.action.extension" value=","/>

Markus


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message