struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yasser Zamani <yasser.zam...@live.com>
Subject Re: Drop JDK6 support in Struts 2.3.x
Date Tue, 27 Jun 2017 15:04:07 GMT
I see that support 2.3.x could be compiled and pass tests by jdk7. I can check jdk8 too when
my pc was available but I think it could too.

So we can keep it as is but use jdk7/8 for build, right?

Lukasz Lenart <lukaszlenart@apache.org> نوشت:

>Looks like Jenkins is going to support JDK8 very soon ...
>
>2017-06-26 12:36 GMT+02:00 Yasser Zamani <yasser.zamani@live.com>:
>> I have same opinion. If it's easy to continue 2.3 support just by dropping JDK6 support,
then it's a more softer decision.
>>
>> Christoph Nenning <Christoph.Nenning@lex-com.net> نوشت:
>>
>>>> Hi,
>>>>
>>>> We still target Struts 2.3.x on JDK6 but there is a lack of support
>>>> for this - at least problems with Jenkins and builds.
>>>>
>>>> What about dropping JDK6 support and switching to JDK7? Or maybe we
>>>> should drop the whole Struts 2.3.x branch - it will happen someday
>>>> anyway.
>>>>
>>>>
>>>> Regards
>>>> --
>>>> Łukasz
>>>> + 48 606 323 122 http://www.lenart.org.pl/
>>>>
>>>
>>>
>>>Hi,
>>>
>>>dropping JDK6 is alright for us. But we still have some apps running with
>>>struts 2.3. We would much appreciate to receive (security) fixes for that.
>>>Could 2.3 be put in some kind of maintenance mode where it does not
>>>receive new features but just fixes?
>>>
>>>
>>>Regards,
>>>Christoph
>>>
>>>This Email was scanned by Sophos Anti Virus
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>For additional commands, e-mail: dev-help@struts.apache.org
>
Mime
View raw message