struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Upgrading do Servlet API 2.5 and JSP API 2.1
Date Wed, 23 Nov 2016 11:56:59 GMT
I prefer to go in small steps:

- Struts 2.6 - Servlets 2.5, JSP 2.1, Java 7
- Struts 3 - Servlets 3.0, JSP 2.2, Java 7
- Struts 4 - ..., Java 8

and as from Struts 3 switch to full Semantic Versioning http://semver.org/


Regards
Lukasz

2016-11-18 13:15 GMT+01:00 Aaron Johnson <johnson.aaron5@gmail.com>:
> +1 for Struts 2.6 with Servlet 3.0 and JSP 2.2
>
> On Thu, Nov 17, 2016 at 2:17 AM, Johannes Geppert <jogep@apache.org> wrote:
>
>> +1 for a 2.6.x based on Servlet 3.0 and JSP 2.2.
>>
>> Best Regards
>>
>> Johannes
>>
>> #################################################
>> web: http://www.jgeppert.com
>> twitter: http://twitter.com/jogep
>>
>>
>> 2016-11-16 18:01 GMT+01:00 Aleksandr Mashchenko <amashchenko@apache.org>:
>>
>> > Maybe Servlet 3.0 and JSP 2.2.
>> >
>> > For example: Apache Tomcat implements both in it 7.0.x series, which is
>> > available since ~2011.
>> > And support for the Apache Tomcat 6.0.x will end on 31 December 2016.
>> >
>> > ---
>> > Regards,
>> > Aleksandr
>> >
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> > For additional commands, e-mail: dev-help@struts.apache.org
>> >
>> >
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message