struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johannes Geppert <jo...@apache.org>
Subject Re: Log4j2 doesn't work with Google AppEngine
Date Mon, 15 Jun 2015 06:56:45 GMT
If we don't get it running with log4j2 on appengine then another option is
maybe to not use log4j2 core in the appengine application.
The users could use slf4j together with a log4j2 -> slf4j bridge.

http://logging.apache.org/log4j/log4j-2.1/log4j-to-slf4j/index.html


Johannes



#################################################
web: http://www.jgeppert.com
twitter: http://twitter.com/jogep


2015-05-29 12:34 GMT+02:00 Lukasz Lenart <lukaszlenart@apache.org>:

> Nope, it didn't help
>
> 2015-05-29 12:25 GMT+02:00 Lukasz Lenart <lukaszlenart@apache.org>:
> > 2015-05-29 11:34 GMT+02:00 Johannes Geppert <johgep@gmail.com>:
> >> According to Stackoverflow [1] you need to disable <property
> >> name="log4j2.disable.jmx" value="true" /> in appengine-web.xml.
> >> Also it should be already solved in log4j2 beta.
> >>
> >> [1]
> >>
> http://stackoverflow.com/questions/16979283/problems-with-using-log4j-2-in-gae
> >
> > I will try but it's a different exception. StatusLogger is trying to
> > access SystemClassLoader which is prohibited.
> >
> >
> > Regards
> > --
> > Ɓukasz
> > + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message