struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Pyeron" <jpye...@pdinc.us>
Subject RE: Struts2 under Jboss-6 ?
Date Mon, 12 Sep 2011 14:47:50 GMT

> -----Original Message-----
> From: Lukasz Lenart [mailto:lukasz.lenart@googlemail.com] 
> Sent: Friday, April 01, 2011 7:38
> To: Struts Developers List
> Subject: Re: Struts2 under Jboss-6 ?
> 
> Hi,
> 
> But this should be just a warning and your application should 
> work as expected.
> And it's known bug -> https://issues.apache.org/jira/browse/WW-3558

How can I tell which release the patch made it into? Or in other words did it
make it into 2.2.3.1?

> 
> 
> Regards
> --
> Lukasz
> + 48 606 323 122 http://www.lenart.org.pl/
> Warszawa JUG conference - Confitura http://confitura.pl/
> 
> 
> 2011/4/1 rop <rop049@gmail.com>:
> > Hi,
> >
> > I was just trying to deploy a simple HelloWorld-type 
> war-applicaton on 
> > Jboss-6.0.0.Final, and could not get it to work.
> >
> > After investigating, I found out what the problem was, and 
> as far as I 
> > can understand, no Struts2 application will currently run 
> on Jboss-6.
> >
> > I could also not find any existing report on this problem.
> >
> > I just wanted to know if there is already some activity planned, to
> > verify+fix Struts2 for Jboss-6?
> >
> > Or if this is already a "known issue", despite my failure 
> to verify it?
> >
> > The Exception you get when trying to deploy is something like:
> >
> > [com.opensymphony.xwork2.util.FileManager]
> > Could not create JarEntryRevision!: java.io.FileNotFoundException:
> >  
> > 
> vfs:\C:\program1\jboss6\server\default\deploy\myapp.war\WEB-INF\lib\st
> > ruts2-sitemesh-plugin-2.2.1.1
> >
> > The problem I found was in org.apache.struts.xwork : 
> xwork-core where 
> > the method URLUtil.isJboss5Url() currently recognizes Jboss 
> > file-protocols:
> >    vfsmemory:
> >    vfszip:
> >    vfsfile:
> >
> > But apparently, in Jboss-6 there is now another 
> file-protocol, called
> >    vfs:
> >
> > Thus the error-msg above.
> >
> > I made a custom-build test and modified the method to also 
> recognize 
> > the "vfs" protocol-name, and then the application deploys 
> and runs OK 
> > on Jboss-6.
> >
> > Should I register this as a jira?
> >
> > 

--
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
-                                                               -
- Jason Pyeron                      PD Inc. http://www.pdinc.us -
- Principal Consultant              10 West 24th Street #100    -
- +1 (443) 269-1555 x333            Baltimore, Maryland 21218   -
-                                                               -
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
This message is copyright PD Inc, subject to license 20080407P00.

 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message