struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Łukasz Lenart <>
Subject Re: Rename @Inject to @StrutsInject
Date Mon, 11 Jul 2011 09:29:23 GMT
This change can simple lower users' confusion and I suggested it base
on my experience. Sometime ago I was developing application with CDI
and RESTeasy - both have @Produces annotation and it was very annoying
to discover such a mistake during unit tests or even UI tests. It's
silly, but it happened to my teammate also, whom didn't expect an
annotation with the same name.

The problem is more context specific, now users don't use @Inject
because most of them don't know about XWork's @Inject, but when they
will start using CDI, they can be confused seeing two the same
annotations suggested by IDE.

Another thing, XWork's @Inject should be used internally or by plugins
developers and occasionally by end-users, naming it @StrutsInject will
state that clearly.

+ 48 606 323 122
Warszawa JUG conference - Confitura

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message