struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kkumarc <kkum...@gmail.com>
Subject RE: Tomcat 7 supported?
Date Tue, 26 Jul 2011 17:21:18 GMT
Hi, 

Can you tell me which jspc library is supported by Tomcat 7?

I tried the method described in this thread
http://community.jboss.org/thread/156757 (which is pasted below also), but i
am not successful.

<plugin>
              <groupId>org.codehaus.mojo.jspc</groupId>
              <artifactId>jspc-maven-plugin</artifactId>
              <version>2.0-alpha-3</version>
              <executions>
                <execution>
                  <goals>
                    <goal>compile</goal>
                  </goals>
                </execution>
              </executions>
              
              <dependencies>
                <dependency>
                  <groupId>org.codehaus.mojo.jspc</groupId>
                  <artifactId>jspc-compiler-tomcat6</artifactId>
                  <version>2.0-alpha-3</version>
                  
                  <exclusions>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>jasper</artifactId>
                    </exclusion>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>jasper-el</artifactId>
                    </exclusion>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>jasper-jdt</artifactId>
                    </exclusion>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>servlet-api</artifactId>
                    </exclusion>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>jsp-api</artifactId>
                    </exclusion>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>el-api</artifactId>
                    </exclusion>
                    <exclusion>
                      <groupId>org.apache.tomcat</groupId>
                      <artifactId>annotations-api</artifactId>
                    </exclusion>
                  </exclusions>
                </dependency>
                
                <dependency>
                  <groupId>org.apache.tomcat</groupId>
                  <artifactId>tomcat-jasper</artifactId>
                  <version>7.0.12</version>
                </dependency>
                
                <dependency>
                  <groupId>org.eclipse.jdt.core.compiler</groupId>
                  <artifactId>ecj</artifactId>
                  <version>3.5.1</version>
                </dependency>
              </dependencies>
            </plugin>

I am getting the following error while running the application 
java.lang.ClassNotFoundException: org.apache.AnnotationProcessor
at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.getDeclaredFields0(Native Method)
at java.lang.Class.privateGetDeclaredFields(Class.java:2291)
at java.lang.Class.getDeclaredFields(Class.java:1743)

regards
krishna

--
View this message in context: http://struts.1045723.n5.nabble.com/Tomcat-7-org-apache-AnnotationProcessor-tp3542535p4635615.html
Sent from the Struts - Dev mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message