struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Stone <xt...@stonescape.net>
Subject Re: [VOTE] Struts 2.1.8.1 Vote
Date Tue, 20 Oct 2009 22:54:25 GMT
Since Struts 2.1.8 is incompatible with FreeMarker 2.4 (bug  WW-2766  
and WW-3275) which is bundled in 2.1.8, I would hope you are  
delivering this build with FreeMarker  2.2.1 (and actually it seems  
fine with 2.3 as well).  However, there are a number of us who use  
FreeMarker and Sitemesh, and this is a major show stopper for us.  If  
not, perhaps a documentation note to say that Struts 2.1.8 is  
incompatible with Sitemesh and FreeMarker 2.4 would be appropriate.   
We had to download the source code of both to see the deprecated code  
and then found these tickets which does include workaround.

If you have bundled 2.1.8.1 with the older FreeMarker, or have updated  
the struts-sitemesh plugin, I can deploy it on our test sites and  
confirm that the plugin works.

-- Christian Stone


On Oct 20, 2009, at 5:49 PM, Musachy Barroso wrote:

> +1 GA. I have been using it and it works fine. I also tested unzipping
> the files in windows xp and that was fixed as well.
>
> musachy


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message