struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Musachy Barroso <musa...@gmail.com>
Subject Re: Class reloading
Date Tue, 22 Sep 2009 03:23:30 GMT
We had the same problem today running showcase in the zone, while it
worked locally for me and Wes. I changed the plugin to lookup those
constants instead of getting them injected, I have no idea what is
going on.

musachy

On Fri, Sep 11, 2009 at 8:17 AM, Musachy Barroso <musachy@gmail.com> wrote:
> one more thing, check that you don't have the spring plugin duplicated
> in the classpath.
>
> musachy
>
> On Thu, Sep 10, 2009 at 9:23 PM, Musachy Barroso <musachy@gmail.com> wrote:
>> I am out of ideas. If the change to the class file to use that
>> constant is there (and it is because it fails), then the constant
>> should be there as well.
>>
>> musachy
>>
>> On Thu, Sep 10, 2009 at 7:59 PM, Dale Newfield <dale@newfield.org> wrote:
>>> Musachy Barroso wrote:
>>>>
>>>> that should not matter, maybe it is not loading your .properties file.
>>>
>>> It is loading it, because once I added a value (false) in my .properties
>>> file it got past that error and began to load.
>>>
>>> I'm not claiming that class reloading isn't working.
>>> I'm not claiming that struts2 isn't working.
>>>
>>> I'm saying I don't use maven, but rather ant so updating dependencies can be
>>> tricky.  Between a failed ACEGI -> Spring Security upgrade, some changes
>>> attempting to make the login accept "username or email address", a bunch of
>>> other dependency updates, code updates, switching to 2.1.8-SNAPSHOT,
>>> changing from
>>> org.apache.struts2.dispatcher.FilterDispatcher/ActionContextCleanUp to
>>> org.apache.struts2.dispatcher.ng.filter.StrutsExecuteFilter/StrutsPrepareFilter,
>>> and who knows what other changes I've managed to completely break my
>>> application.  I'm attempting to back out various of those changes to get it
>>> working again (and was just trying to turn off the reloading bit so that I
>>> knew that had nothing to do with it), but I can't even display the login
>>> form right now.
>>>
>>>> Make sure you do an mvn clean install..just to satisfy the maven dark
>>>> gods
>>>
>>> I did have to skip the tests to get xwork to compile, too--now that I think
>>> about the error I bet it was a java5/java6 thing, too...
>>>
>>>> http://www.codeodor.com/images/works-on-my-machine-starburst.png :)
>>>
>>> Yeah.  I guess it would be nice if xwork/struts HEAD could get released (and
>>> hopefully go GA) so I would know my java5 compilation environment isn't
>>> screwing up anything important.
>>>
>>> -Dale
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>>> For additional commands, e-mail: dev-help@struts.apache.org
>>>
>>>
>>
>>
>>
>> --
>> "Hey you! Would you help me to carry the stone?" Pink Floyd
>>
>
>
>
> --
> "Hey you! Would you help me to carry the stone?" Pink Floyd
>



-- 
"Hey you! Would you help me to carry the stone?" Pink Floyd

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message