struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David C. Hicks" <dhi...@i-hicks.org>
Subject Re: Can I build using Struts 2.1.8-SNAPSHOT?
Date Wed, 30 Sep 2009 20:01:27 GMT
Musachy Barroso wrote:
> what's this problem in that ticket? Jira is down atm,
>   
A NPE thrown from OpenSymphony FileRevision.needsReloading().  It
appears to have something to do with enabling "devMode" in a build and
having Tomcat installed in a directory in which there was a space
somewhere in the path.

We keep devMode enabled for all development builds and then disable it
when building our QE releases.  We had not run into this problem until
we began to integrate some GWT into our code.  Then, it only affected
one developer who is working on Windows.  (The rest of us are on Linux
and/or Mac OS X.)  I'm not sure that the OS has anything to do with the
problem.  It's just an interesting piece of data, probably.

Looking closer, it appears that the actual patch was submitted to XWork
back in January.

> musachy
>
> On Wed, Sep 30, 2009 at 12:40 PM, Wendy Smoak <wsmoak@gmail.com> wrote:
>   
>> On Wed, Sep 30, 2009 at 12:32 PM, David C. Hicks <dhicks@i-hicks.org> wrote:
>>
>>     
>>> Yes, you did send me in this direction.  Thank you!  I must have missed
>>> the repository information in the thread.  I'll go back and look again.
>>> I'm really trying not to ask too many questions here - especially, in
>>> the light of the current release vote going on.  In my mind, the effort
>>> to get the release out is far more important that my being able to build
>>> from the snapshot.  I was just hoping that I could try this out.  (This
>>> defect appears to be what is keeping one of my team from being able to
>>> participate in some of the work we're doing right now.  Fortunately, we
>>> do have other work that he can do, instead.)
>>>       
>> You're too close to give up now. ;)
>>
>> Here's the thread:  http://www.nabble.com/Struts-2.1.8-Vote-td25577514.html
>>
>> The staging repo is
>> http://people.apache.org/builds/struts/2.1.8/m2-staging-repository/
>>
>> Use <version>2.1.8</version> for the artifacts.
>>
>> You're welcome to ask if you need more help, that's what the list is for.
>>
>> --
>> Wendy
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> For additional commands, e-mail: dev-help@struts.apache.org
>>
>>
>>     
>
>
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message