struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Musachy Barroso" <musa...@gmail.com>
Subject Re: [jira] Commented: (WW-2778) autocomplete in struts 2
Date Fri, 29 Aug 2008 19:42:30 GMT
Please, post your questions on the user list, believe it or not you
have a better chance of finding a solution there.

musachy

On Fri, Aug 29, 2008 at 3:38 PM, MyAshok <takumar.eng@gmail.com> wrote:
>
> hi,
>
> same code is working in some other jsp. I think the current issue is because
> of the line <s:a> is placed inside s:iterator. This is just a extra info.
>
> thanks
> ashok
>
>
>
>
>
> MyAshok wrote:
>>
>> Hi all,
>>
>> Pls help me asap.
>>
>> Same error but in s:a
>>
>> <s:a theme="ajax" href="/viewdetail.action" id ="url1"
>> showLoadingText="false" targets="mainpage">Hai</s:a>
>>
>>  I think everything is correct, but showing in debug mode xmlhttptransport
>> error callback failed:[object Error]
>>
>> With Hope,
>> Ashok.
>>
>>
>>
>>
>>
>> JIRA jira@apache.org wrote:
>>>
>>>
>>>     [
>>> https://issues.apache.org/struts/browse/WW-2778?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=44597#action_44597
>>> ]
>>>
>>> Dave Newton commented on WW-2778:
>>> ---------------------------------
>>>
>>> Eventually, probably--you just filed it yesterday.
>>>
>>> You can help your own cause by providing a patch.
>>>
>>>> autocomplete in struts 2
>>>> ------------------------
>>>>
>>>>                 Key: WW-2778
>>>>                 URL: https://issues.apache.org/struts/browse/WW-2778
>>>>             Project: Struts 2
>>>>          Issue Type: Bug
>>>>          Components: Plugin - Dojo Tags
>>>>    Affects Versions: 2.0.11.2
>>>>         Environment: Miscrosoft Windows XP 2002
>>>>            Reporter: Dilip Parihar
>>>>         Attachments: autocomplete.JPG
>>>>
>>>>
>>>> <s:autocomplete ..... > do not fetch any result from action class and
>>>> does nothing.
>>>> Reported this error using Internet Explorer 7.0
>>>> DEBUG: XMLHttpTransport error callback failed: TypeError: node is null
>>>> Using firefox autocomplete shows this error.
>>>> DEBUG: [SyntaxError: missing } in XML expression, file:
>>>> http://localhost:8080/MusicAwards/struts/dojo/dojo.js, line: 141]
>>>> <s:url ......> tested using <s:div> tag.
>>>> <s:div theme="ajax"
>>>>                href="%{jsonList}" loadingText="Loading info..."
>>>> indicator="indicator1"/>
>>>> Results in the same error on dojo.js line 141 (node is null).
>>>> Check
>>>> http://www.planetstruts.org/struts2-showcase/ajax/autocompleter/
>>>> last example of 'color' and 'fruit' it shows similar error.
>>>>  <s:autocompleter ...> and <s:div....> both are not workiing
in struts
>>>> 2.0.11.2 in Internet Explorer 7.0 or Firefox.
>>>
>>> --
>>> This message is automatically generated by JIRA.
>>> -
>>> You can reply to this email to add a comment to the issue online.
>>>
>>>
>>>
>>
>>
>
> --
> View this message in context: http://www.nabble.com/-jira--Created%3A-%28WW-2778%29-autocomplete-in-struts-2-tp19079114p19226204.html
> Sent from the Struts - Dev mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>



-- 
"Hey you! Would you help me to carry the stone?" Pink Floyd

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message