struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nils-Helge Garli Hegvik" <nil...@gmail.com>
Subject Re: Struts 2 archetypes
Date Sat, 23 Aug 2008 17:30:57 GMT
I'm guessing you have conflicting versions of the servlet api on the
classpath. Try with debug logging enabled and take a look at the
dependencies that are loaded.

Nils-H

On Sat, Aug 23, 2008 at 7:22 PM, Wendy Smoak <wsmoak@gmail.com> wrote:
> Our user docs point to snapshots of the archetypes, which is not
> ideal.  Especially since old snapshots were removed recently by infra
> to free up disk space, and the commands in the docs no longer work.
>
> I've branched the blank and starter archetypes [1], updated them to
> version 2.0.11.2-SNAPSHOT, and deployed new snapshots.
>
> Can someone please try the blank archetype and figure out why 'mvn
> jetty:run' does not work?  I get:
>
> mvn archetype:create -DarchetypeArtifactId=struts2-archetype-blank
> -DarchetypeVersion=2.0.11.2-SNAPSHOT
> -DarchetypeGroupId=org.apache.struts -DgroupId=net.wsmoak
> -DartifactId=test123
>
> cd test123
>
> mvn install jetty:run
>
> http://localhost:8080/test123
>
> HTTP ERROR: 500
>
> javax.servlet.jsp.tagext.TagAttributeInfo.<init>(Ljava/lang/String;ZLjava/lang/String;ZZLjava/lang/String;ZZLjava/lang/String;Ljava/lang/String;)V
>
> RequestURI=/test123/example/HelloWorld.action
>
> [1] svn co https://svn.apache.org/repos/asf/struts/maven/branches/ARCHETYPES_2_0_X
>
> Thanks,
> --
> Wendy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message